Issue

Some customers of our light + sound kits for the LEGO(R) Millennium Falcon have experienced trouble when trying to add three custom sounds to the engine sound module as outlined in the instruction manual.

Symptoms

The engines sound module for the Falcon supports up to three user-created MP3 sound files, which can be played in random order by pressing buttons on the included infrared remote control unit.  When users copy three custom sound files onto the engines sound module, only two can be played.  Instead of playing the third sound, the sound module plays silence.  There is no way to get the module to play the third sound.

Cause

This happens when a Macintosh computer is used to copy files onto the sound module.  As soon as the sound module is connected to the Mac, the operating system creates two hidden folders that it uses for tasks like managing the trash and other functions.  These folders interfere with the way in which the sound card "sees" files on the sound card, preventing it from being able to "see" and play the third sound that was copied onto the module.  The sound module does not use file names to play sounds, but rather accesses files by number in the sequence in which they are copied to the module from the computer.  The hidden folders created by the Mac's operating system interfere with this sequence, as the folders always look like the most recently-created files to the sound module.  When it attempts to play user-created sounds, it sees the Mac folders as "files" and tries to play them, which does not work.  This is the reason the third custom sound cannot be played.

Unfortunately there is no way to completely and permanently remove these Mac-generated folders from the sound module's memory (MacOS will always re-create them), so they will always bump the third sound out of play range in the file listing.  This does not happen on a Windows computer, so there is no way we could anticipate whether a customer would use a Mac or Windows machine to copy files onto the module when it was formatted at our factory.

Resolution

Because this issue is caused by the Mac operating system and the way in which it uses memory devices, there is no work-around for customers who only have access to a Mac.  Once the sound module is connected to a Mac computer, from that point onward the third custom sound will be inaccessible.  The first two sounds will be able to be played as normal.  This happens even if you connect the sound module to a Windows computer after it was once connected to a Mac.

To resolve this issue, the customer needs access to a Windows PC.  If this can be arranged, the following steps can be followed to restore the memory on the sound module and access all three user-created sound files:

  1. Disconnect the sound module from the power used in your Millennium Falcon model.
  2. Connect the sound module to a Windows computer.  File Manager should open the memory drive on the sound module (this may appear as drive "D:" on the computer).
  3. There should be five sound files named "DO NOT DELETE" on the memory drive of the sound card, each numbered 01 through 05.  Copy these files from the memory of the sound module onto the desktop of your Windows computer.
  4. If you have copied any custom sounds onto the sound module, they will appear after the fifth "DO NOT DELETE" file (sound 05).  Copy your custom sound files to the Windows desktop as well.
  5. Validate that you have all five "DO NOT DELETE" files copied onto your Windows computer.  In the next step, you will ERASE the memory on the sound card, and you will lose the factory-installed sound files.  This is why you need to have a copy of each on your Windows computer.
  6. After you have validated that copies have been made onto your Windows computer, use the Format command in Windows Explorer to erase and re-format the memory drive on the sound module (right-click on the drive letter and select "Format..."  Complete the steps to erase and re-format the drive.
  7. After you receive the format confirmation messages, you should see the memory drive on the sound module is now showing a blank directory (no files).
  8. Re-copy the factory-installed sound files onto the sound module's memory drive by copying ONE AT A TIME in their ORIGINAL ORDER back onto the newly-formatted drive.  So you will copy the file with number "01" first, then the file with number "02" and so on, until you have copied all five files.  Files must be copied one at a time in the order indicated by their number.  Files cannot be "batch copied" by selecting all and copying to the sound module; they must be copied one by one, and they must be copied in the correct order.
  9. After you have copied all five original files back onto the sound module's memory drive, you can copy up to three custom sounds onto the drive as well.  Make sure these are copied last, after all five of the original files have been restored to the memory drive.
  10. Disconnect the sound module from the Windows computer and re-connect it to the power and control connections inside your Millennium Falcon setup.  Sounds should now play as normal and you should be able to access all three custom sounds.
  11. Do not connect the sound module to a Mac again in the future.

 

While we realize this is a frustrating experience for Mac users, we hope the troubleshooting steps above will resolve the issue.  If you do not have access to a Windows computer and you need to play three custom sounds, please contact us at support@brickstuff.com and we can make arrangements to have you ship your sound module back to our factory where we can add your custom sounds using our Windows computers to copy files for a small fee, and then ship your module back to you.